summaryrefslogtreecommitdiff
path: root/dev-python/priority/priority-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/priority/priority-1.3.0.ebuild')
-rw-r--r--dev-python/priority/priority-1.3.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/priority/priority-1.3.0.ebuild b/dev-python/priority/priority-1.3.0.ebuild
deleted file mode 100644
index 39cb4d69564a..000000000000
--- a/dev-python/priority/priority-1.3.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
-
-inherit distutils-r1
-
-DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
-HOMEPAGE="https://python-hyper.org/priority/en/latest/
- https://github.com/python-hyper/priority
- https://pypi.org/project/priority/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd"
-IUSE="test"
-
-RDEPEND=""
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
- cd test
-}