summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python/protobuf-python-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-9999.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index fc808ec3a2a3..faaae29a1aa5 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8,3_9})
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
@@ -44,6 +43,11 @@ if [[ "${PV}" == "9999" ]]; then
fi
python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply "${FILESDIR}/${PN}-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
+ eapply_user
+ popd > /dev/null || die
+
distutils-r1_python_prepare_all
sed -e "/^[[:space:]]*setup_requires = \['wheel'\],$/d" -i setup.py || die