summaryrefslogtreecommitdiff
path: root/dev-python/pyFFTW/pyFFTW-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyFFTW/pyFFTW-9999.ebuild')
-rw-r--r--dev-python/pyFFTW/pyFFTW-9999.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/dev-python/pyFFTW/pyFFTW-9999.ebuild b/dev-python/pyFFTW/pyFFTW-9999.ebuild
index db7b32f540a5..2561ff31ec5b 100644
--- a/dev-python/pyFFTW/pyFFTW-9999.ebuild
+++ b/dev-python/pyFFTW/pyFFTW-9999.ebuild
@@ -1,39 +1,45 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 git-r3
DESCRIPTION="A pythonic python wrapper around FFTW"
-HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
+HOMEPAGE="
+ https://github.com/pyFFTW/pyFFTW/
+ https://pypi.org/project/pyFFTW/
+"
+EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
LICENSE="BSD"
SLOT="0"
-if [[ "${PV}" = "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
DEPEND="
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
>=sci-libs/fftw-3.3:3.0=[threads]
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
test? (
>=dev-python/dask-1.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.8.0[${PYTHON_USEDEP}]
)
"
distutils_enable_tests unittest
+src_configure() {
+ # otherwise it'll start with -L/usr/lib, sigh
+ export PYFFTW_INCLUDE_DIR="${EPREFIX}/usr/include"
+ export PYFFTW_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
python_test() {
cp -r -l -n tests/ "${BUILD_DIR}/lib" || die
cd "${BUILD_DIR}/lib" || die