summaryrefslogtreecommitdiff
path: root/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch')
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch b/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
new file mode 100644
index 000000000000..7f8cf6815d03
--- /dev/null
+++ b/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
@@ -0,0 +1,27 @@
+--- pyalsa-1.1.6/setup.py
++++ pyalsa-1.1.6/setup.py
+@@ -70,24 +70,3 @@
+ 'alsamixer',
+ 'alsaseq'
+ ]
+-
+-uname = os.uname()
+-dir = 'build/lib.%s-%s-%s/pyalsa' % (uname[0].lower(), uname[4], sys.version[:3])
+-files = os.path.exists(dir) and os.listdir(dir) or []
+-for f in SOFILES:
+- path = ''
+- for f2 in files:
+- if f2.startswith(f + '.') and f2.endswith('.so'):
+- path = dir + '/' + f2
+- break
+- if not path or not os.path.exists(path):
+- continue
+- p = 'pyalsa/%s.so' % f
+- print("%s -> %s" % (p, path))
+- try:
+- st = os.lstat(p)
+- if stat.S_ISLNK(st.st_mode):
+- os.remove(p)
+- except:
+- pass
+- os.symlink('../' + path, 'pyalsa/%s.so' % f)