summaryrefslogtreecommitdiff
path: root/dev-python/pyalsa/pyalsa-1.0.29.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyalsa/pyalsa-1.0.29.ebuild')
-rw-r--r--dev-python/pyalsa/pyalsa-1.0.29.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.0.29.ebuild b/dev-python/pyalsa/pyalsa-1.0.29.ebuild
new file mode 100644
index 000000000000..7241660b6ade
--- /dev/null
+++ b/dev-python/pyalsa/pyalsa-1.0.29.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy ) # Still py2 only it appears
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for ALSA library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="mirror://alsaproject/pyalsa/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-no-build-symlinks.patch" )
+
+python_configure_all() {
+ # note: this needs changing when py3 becomes supported
+ append-flags -fno-strict-aliasing
+}
+# Testsuite appears to require installed state