summaryrefslogtreecommitdiff
path: root/dev-python/pyalsa/pyalsa-1.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyalsa/pyalsa-1.1.6.ebuild')
-rw-r--r--dev-python/pyalsa/pyalsa-1.1.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.1.6.ebuild b/dev-python/pyalsa/pyalsa-1.1.6.ebuild
new file mode 100644
index 000000000000..9f25f2ab8f50
--- /dev/null
+++ b/dev-python/pyalsa/pyalsa-1.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for ALSA library"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="mirror://alsaproject/pyalsa/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch" )
+
+# Testsuite appears to require installed state