summaryrefslogtreecommitdiff
path: root/dev-python/pychroot/pychroot-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pychroot/pychroot-9999.ebuild')
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index e1419b49ab2e..218709a73ba5 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -24,18 +24,14 @@ RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
fi
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- esetup.py build_man
-}
python_test() {
esetup.py test
@@ -43,6 +39,6 @@ python_test() {
python_install_all() {
local DOCS=( NEWS.rst README.rst )
- esetup.py install_man --mandir="${ED}/usr/share/man"
+ [[ ${PV} == *9999 ]] || doman man/*
distutils-r1_python_install_all
}