summaryrefslogtreecommitdiff
path: root/dev-python/pyclamd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyclamd')
-rw-r--r--dev-python/pyclamd/Manifest1
-rw-r--r--dev-python/pyclamd/pyclamd-0.4.0-r6.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyclamd/Manifest b/dev-python/pyclamd/Manifest
index eec419f78abb..abae4be44e59 100644
--- a/dev-python/pyclamd/Manifest
+++ b/dev-python/pyclamd/Manifest
@@ -1,4 +1,5 @@
AUX pyclamd-0.4.0-remove-obsolete-bugtrack_url.diff 827 BLAKE2B 785e75cf5094fd32e205eb1db5749ebf6fea1fb415aee3a1fe587864147ab6a81340b85d24313e17c5ea1d6467beb8392fe5c5c3c30ce6a9afc50f38e6d04520 SHA512 23fb59f17a498a6f10da49eb23e728366c0e6101ce588c76eec818658fad75390c6437b094bbec42b10dcca4465793862e511d311d4b3ba020f4c13f85f767ec
DIST pyClamd-0.4.0.tar.gz 11177 BLAKE2B cb69c9e1fec936d416a18658a2c3e9df4dc4684cf56c19e8a02ad9929b4c86d9985395c38a8f88f7053f81fe08fa3574c6a206bcc519a9494c2a61caf6b995b1 SHA512 b96e26729e0fe2600572534c0fa22a01238761589f1771e72a054dde9c1b8f122493c83ca04cffda167f7a0e44fbf309bdf76b8fe1de499ec50d56c677923bd4
EBUILD pyclamd-0.4.0-r5.ebuild 611 BLAKE2B e802bd098bf40c1ae75ce6ef4a47a4597f231bb1a97ed08ee6db7f74004ea037575cafe55c2389bf704d5f662a90102ff71c3670c947238ba0415bdba0150f53 SHA512 f6b7d32eeec191ad4a465af35463bdcb9e9c1b44aeddd4ce44625449aa25042949941088aff407e29381702b50bdb3735b89b43792fd7d7953d778811a9be272
+EBUILD pyclamd-0.4.0-r6.ebuild 611 BLAKE2B 4a2fc5349551a68ae2a4a7c03788e3f9050dd886704a48574ed62860bce8d5342ad99359fd0a8c1dd21ea842b5d5e881f7ef72787f9ef0768489071a3333c893 SHA512 36ab046e6001d85bb778000528442b3dee03ffdbd5370d5d857970d36661b12dca6a5a7aa02617aafc2f385341b085f8ef7b21459383c3fa0e2cb807f1788a4d
MISC metadata.xml 295 BLAKE2B cda80e8a0e2125cf0a97ab3ea3c63f588fb57afc25d1559cea145e09676c7708f2c7aa271a7cccabde61927f8a6e5e3200b6ce5b4597eb9a8065f7938fe9201a SHA512 54f6204e9620ddfa126858fd5c5ae7400245759999362f355287276df4d6a255d34322bd70e08b875bbbfceec7099b39db214008a6ea5458a74845d3a39e3952
diff --git a/dev-python/pyclamd/pyclamd-0.4.0-r6.ebuild b/dev-python/pyclamd/pyclamd-0.4.0-r6.ebuild
new file mode 100644
index 000000000000..8a43f0173ab0
--- /dev/null
+++ b/dev-python/pyclamd/pyclamd-0.4.0-r6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=pyClamd
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to Clamd (ClamAV daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-remove-obsolete-bugtrack_url.diff" )