summaryrefslogtreecommitdiff
path: root/dev-python/pycmd/pycmd-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycmd/pycmd-1.2.ebuild')
-rw-r--r--dev-python/pycmd/pycmd-1.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pycmd/pycmd-1.2.ebuild b/dev-python/pycmd/pycmd-1.2.ebuild
new file mode 100644
index 000000000000..613ea33004bf
--- /dev/null
+++ b/dev-python/pycmd/pycmd-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pycmd: tools for managing/searching Python related files"
+HOMEPAGE="https://pypi.python.org/pypi/pycmd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Test files present however are not ready to run as they are supplied in the source
+# The source repo is not listed at all in the page @pypi.