summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.12.1.ebuild20
2 files changed, 19 insertions, 3 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index b28758efd4bf..a55a6ca3c1a6 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,3 +1,3 @@
DIST pycodestyle-2.12.1.gh.tar.gz 80518 BLAKE2B e64dda57d1c349228f8ffeced4061d278b342af7db152377e34b3fad626db52f7eef4668df60d323196f1844e8fa28d9e231cc216145b2ea1da6ae32bc1f341f SHA512 7709c0611812c3294a55a5e6dde00d5affc67c4273ab1d37dec507a424b618b2736a6976d27872903fa448f208fe2ba4529f2bfbefc2902dcf947cb6bca5b09a
-EBUILD pycodestyle-2.12.1.ebuild 821 BLAKE2B 61dcc4d1596d0a01a07f7e0e974add3550eb8c27d9d147b8742fcb4ab509283acaa51e232844ec40ce668486f33d75d3ce931f076902f1f1963b53b8006614e7 SHA512 dfeb211561519bda9496fb106a3db0ef7893dc095e591b434b2f8c2dd132a65dc0f550147a94868654ecde07d5d24419ba199de2197e59c3a26d971e175f6289
+EBUILD pycodestyle-2.12.1.ebuild 1106 BLAKE2B 7e62a8a3b372d555d75f0a5a9551de6738f5665e0201c57926bacb9c506b4c6a9a61b070fddbef189457e458b41e828bf265897b8d15c1e33e74f3ae3e043d7c SHA512 e4d1974fa910931cb1dd63da6bffa05acfefcf0cd38742a91da35b97fb8a59b02faae22a45667c638b1479dbca20b55069f53fb98f88e0efc53caa10df1309fc
MISC metadata.xml 409 BLAKE2B 86d114cb53a68c8c24caebef1287bce1ae99cd652bca1fe2f19cce870c66490521329133a1fea47c79bd8c64d2bcd945022e31ac7db7885e9a4dea4d50f19a04 SHA512 e1de2014c44c8fdaf71ac26af406d27ab76cfd377dc20bb36e36bfbeab79f8e8981e8834e04b8e0bddd92d231b275e56e91d87570fee5ad426418a4abd00d4be
diff --git a/dev-python/pycodestyle/pycodestyle-2.12.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.12.1.ebuild
index 87c37d6a5885..c202e6c9ee7f 100644
--- a/dev-python/pycodestyle/pycodestyle-2.12.1.ebuild
+++ b/dev-python/pycodestyle/pycodestyle-2.12.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
inherit distutils-r1
@@ -27,3 +27,19 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390
distutils_enable_sphinx docs \
dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3.11)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/5234
+ tests/test_api.py::APITestCase::test_check_nullbytes
+ )
+ ;;
+ esac
+
+ epytest
+}