summaryrefslogtreecommitdiff
path: root/dev-python/pycurl/pycurl-7.43.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycurl/pycurl-7.43.0.5.ebuild')
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.5.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pycurl/pycurl-7.43.0.5.ebuild b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
index 046812098a77..208be0af1b8f 100644
--- a/dev-python/pycurl/pycurl-7.43.0.5.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
@@ -3,8 +3,9 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=manual
# The selftests fail with pypy, and urlgrabber segfaults for me.
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1 toolchain-funcs
@@ -17,7 +18,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl examples ssl test"
RESTRICT="!test? ( test )"
@@ -54,6 +55,8 @@ PATCHES=(
python_prepare_all() {
sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ # disable automagic use of setuptools
+ sed -e 's:import wheel:raise ImportError:' -i setup.py || die
# these tests are broken with newer versions of bottle
sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
distutils-r1_python_prepare_all