summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest1
-rw-r--r--dev-python/pycxx/pycxx-7.1.8-r2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index 3a0398fb8d27..444ea2499b42 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,4 @@
DIST pycxx-7.1.8.tar.gz 154789 BLAKE2B e4b635d4b53ae3fd0790d6eddcd465acfc5272213e9752e7c2a1840edddb66f09bc9617373246964859125a27dc82110de6b4f4ffa44c41c94c338c846490e47 SHA512 3c9c3a23dfa9777c6a48b8600e7336cbadb60080a1051071583d534ead6c691dd9d304613073d6fb0c632eb1703b043b4214826c0ae7bd4b2ca72203ec03c0a2
EBUILD pycxx-7.1.8-r1.ebuild 1212 BLAKE2B 35d6e6df627dd74085e8c5854f9d7aae010cebf535674d082a4943163c5b488b9bbe5296a79882be6d843073222c232e3d58fff6549f36d14aca61d0071310c6 SHA512 cb6179b73b88d0187bdca85ddc76cced6862320dbbbba617d8cdcdf7a2c9b838038290fbec04f3cf2e5eabd9fc99e5bf998f1e869c0261549394efc65a1cedb8
+EBUILD pycxx-7.1.8-r2.ebuild 1267 BLAKE2B 3f0783e57673010a7334c61b42b758f6317e692a6591c0aa0cda0407fced57393655ef031aefb5db402c50aafa4668c347554e5b61f6f6afbac2c0114a75a70f SHA512 5192757674ff0393e521e84e161d60e8f4a16ede00c77e6c9e476b1b7c36950999c7992b1cae19f1d979fef5d9149e94ea7598bd86b826a18f23705b7ae696a5
MISC metadata.xml 741 BLAKE2B 0704aeaef1fff687aa8374876e9d275a135d4ead7fabc938d8b3dc60954717fcf01bb79e8e9a72483184b13441d65294f41f7b5b0b19bebbf42c0934993723f4 SHA512 0b4f912fa2e38882bcaecede459f34270dd222a94bf70fa019e8de1eb1097c9c9016405b9b8a7933fd7839f11404a18c5e2ce7d4b4336a7121e86605903a8901
diff --git a/dev-python/pycxx/pycxx-7.1.8-r2.ebuild b/dev-python/pycxx/pycxx-7.1.8-r2.ebuild
new file mode 100644
index 000000000000..a480ed5ca839
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.8-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="https://cxx.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' 3.12)
+"
+
+python_prepare_all() {
+ rm -R Src/Python2/ || die
+
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Move misplaced files into place
+ dodir "/usr/share/${EPYTHON}"
+ mv "${D}/usr/CXX" "${D}/usr/share/${EPYTHON}/CXX" || die
+ mv "${D}/usr/include/${EPYTHON}"/{cxx,CXX} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python3/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}