summaryrefslogtreecommitdiff
path: root/dev-python/pydantic-core/pydantic-core-2.18.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydantic-core/pydantic-core-2.18.2.ebuild')
-rw-r--r--dev-python/pydantic-core/pydantic-core-2.18.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pydantic-core/pydantic-core-2.18.2.ebuild b/dev-python/pydantic-core/pydantic-core-2.18.2.ebuild
index eaf0ce478b6f..11abc1d00ee8 100644
--- a/dev-python/pydantic-core/pydantic-core-2.18.2.ebuild
+++ b/dev-python/pydantic-core/pydantic-core-2.18.2.ebuild
@@ -145,5 +145,7 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
rm -rf pydantic_core || die
+ # tests link to libpython, so they fail to link on pypy3
+ [[ ${EPYTHON} != pypy3 ]] && cargo_src_test
epytest -p pytest_mock -p timeout
}