summaryrefslogtreecommitdiff
path: root/dev-python/pydot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/Manifest2
-rw-r--r--dev-python/pydot/pydot-3.0.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index 4ee9a9f86b77..2de1f57fec51 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1,3 +1,5 @@
DIST pydot-3.0.1.gh.tar.gz 280784 BLAKE2B d87d06bf5f62ae783ecb4ff6a16b0986969de49cbf45e120df5e722620fe614181700f8117b0a6ce24fd4aac4f618d4dc16c631f581ebb19bea73a5a92437585 SHA512 6aca6e91134e481334c12a7669d3f5df1181f9a4e2ab914a6c8ab87f28d0afa9d97cfc0d9b665d9fdedb3c335624d68967d491f79fc669573aa81cf1401316cd
+DIST pydot-3.0.2.gh.tar.gz 295058 BLAKE2B dac56e82520c09f3000f7c6bf04d8d933f22958086675d8c7e26572d039388f7561b3aa7150e49cc1957d44dcdd4828058369ccf2ba5f88a9280f67dcbc18196 SHA512 b24b2073781b6c3256e3d9e76514193493d8a8d9eadc8ef1db3d13b7c4d3ddbdcfcc008b3b70abbe9dcb11d2036b4b3a3dda6ca13277fb5413f699a136a58b80
EBUILD pydot-3.0.1.ebuild 865 BLAKE2B d51c73fa1c183d12ca8d436e8054ba13f2be9962b1ec58c9d2ee616d380881fbb2f57070ed661f6fa0dd90533c889ce9e685164064c1a00ddb2c32ed9ed6ea6b SHA512 1f0fc5d970da40d10e2bde578e2caea19c0585a3b7d1c1425eebde061c2d966662d543b5e79a62180941423d1290a7e4b7e8ccb44ae9bc3c3756eacfd5514baf
+EBUILD pydot-3.0.2.ebuild 866 BLAKE2B 4106819bce263ed9790c76e26fc66afd0e3732607d3bf946cf6a3aa23fe00ac7900f1b1a89d7d96f2c4e8f4ef91c6c98a65a5f5b3478a01a8c35294e99f841e6 SHA512 d5d4e0c4253f9dd03ef6cff5e8663c41a8fe028ea58847f15c7b3b171aa1c339b3a41051d666c244cd2930bec2d6c3f779aa90b78d16d4eb2f581f89867c146e
MISC metadata.xml 372 BLAKE2B faad24394ef27dedc8b563e505444b414fe95cb6097bd2bebe01232e68c975b77d415c2a05ec1ad19f0ce1218d1c3f057beea6deecef01b940962a287ad8ce46 SHA512 281a6e2097fcf978f7e691640e257a5f60b242570f8a5715e078363c5658b96b50d3c29ccaad448c0b2ac3dd7b898dcae457bafdb08952163de8d1af81954d75
diff --git a/dev-python/pydot/pydot-3.0.2.ebuild b/dev-python/pydot/pydot-3.0.2.ebuild
new file mode 100644
index 000000000000..849a61311a4e
--- /dev/null
+++ b/dev-python/pydot/pydot-3.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="
+ https://github.com/pydot/pydot/
+ https://pypi.org/project/pydot/
+"
+# pypi releases don't include tests
+SRC_URI="
+ https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest