summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml/pygccxml-1.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygccxml/pygccxml-1.7.5.ebuild')
-rw-r--r--dev-python/pygccxml/pygccxml-1.7.5.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pygccxml/pygccxml-1.7.5.ebuild b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
deleted file mode 100644
index 76be4114be40..000000000000
--- a/dev-python/pygccxml/pygccxml-1.7.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
-HOMEPAGE="https://github.com/gccxml/pygccxml"
-SRC_URI="https://github.com/gccxml/pygccxml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="freedist Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
- app-arch/unzip
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-cpp/gccxml-0.6"
-
-python_compile_all() {
- use doc && emake html man
-}
-
-python_test() {
- "${PYTHON}" unittests/test_all.py
-}
-
-python_install_all() {
- if use doc ; then
- local HTML_DOCS=( docs/_build/html )
- doman docs/_build/man/${PN}.1
- fi
-
- distutils-r1_python_install_all
-}