summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest3
-rw-r--r--dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch21
-rw-r--r--dev-python/pygccxml/pygccxml-2.4.0.ebuild3
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index c08ddd912f50..d01fb64941e2 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -1,4 +1,5 @@
+AUX pygccxml-2.4.0-doc.patch 798 BLAKE2B f062375f40ada000fd266f50d6fdf3ab70ef744c2dfdf29e4d80d1a2008fd910e09053f6cff0ee9b7fd0bd7b263331ca40a1349b821e2203a16a04032ada5a94 SHA512 357b35fa379f90ce56a391b54ff9b4550845747c79fd5c0f3b0a331adfbf5e157c7b9e2a0a7ea2b5929a4074e4ff02b7553d8131961c86b1993fbb627179c729
AUX pygccxml-2.4.0-pyproject.patch 283 BLAKE2B a25ad74f57a6cdebdb83bc49b1ec833a12362be53781f4f72679ac2eeeec3a6649a556af9b8efb3c480d4bc8a23672e4c165ed2c8c39d90cbc8bc980f9834eec SHA512 87b4b24669dbf70bd14276e551b21c0f142ad8661b579a6bfebe9342c716dd1dfa0eb47f7906fc160effa8a9117be0af312b7aed3a36e6f7a3fe0a54a1784c79
DIST pygccxml-2.4.0.gh.tar.gz 3165189 BLAKE2B 855b0b6313be29e7719abe4cc6e654904657c11bfd7310d647227ce9d7760821eeb348dcd9892afbcc3d467db96daaf3010e92803fe28962db9a255cf81eae46 SHA512 48bf4887344c68d0a93a3908cc0a744f3d6a74dce92be88527e85cf7ba1a46f88560730dce0b858f31523cada836aad40461de935c5c2a041de0fa2ae5e38c30
-EBUILD pygccxml-2.4.0.ebuild 748 BLAKE2B d27f3b924677129c20bc26c42f3f0be52ee3fae6db0ab714a1678ea81b8a852ecf75a2362d65c440584aa2265d45bb77fe2c35a689245fda8e07412e6738917e SHA512 52044169e62aa4c933634f97715b5907b41039828848e860b550a426cfbae94dc5dc4c5289edf84fd7f3bfce778aacd1fd30c2619ccf4bc03b11dcbac9305ad0
+EBUILD pygccxml-2.4.0.ebuild 792 BLAKE2B f0fde6f95674c976d421039dcace600d842655305b14968aea9cc8cc3336e0d7ecd83e254249d2657932b8b995d13af9e897086acd326b067bdc24836e20dd07 SHA512 7f2329d8289865fad19b57012506d20c20b7d4cd18382fb53998e59dc1e84b7cc146b4cf658592b46653ce45c47dbf5661b06fb1071239ac88c007ede464a497
MISC metadata.xml 471 BLAKE2B 7d50e5a82bc02e898dcce546775fb4b4d71277097489bc3765eface8cdea1cfa7707a1e60b33e5b5f425ef72ef4b17a7d477df38ba65e8defb4c608cd627d679 SHA512 2b87abc970fe6b3838d3a72e849f6ff84f3c23f4257377d0426d5e8853512ad2fbbb4dae36fe7be7b02664ab64b0eb87e92a42e3d84abc54540aef1fcfc67581
diff --git a/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch b/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch
new file mode 100644
index 000000000000..ecec89c14ed9
--- /dev/null
+++ b/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch
@@ -0,0 +1,21 @@
+diff --git a/docs/conf.py b/docs/conf.py
+index 071ebb1..2ccec1f 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -23,7 +23,6 @@ import importlib.metadata
+ # documentation root, use os.path.abspath to make it absolute, like shown here.
+ sys.path.insert(0, os.path.abspath('.') + "/../src")
+
+-from release_utils import utils # nopep8
+
+ # -- General configuration ------------------------------------------------
+
+@@ -284,7 +283,7 @@ def run_apidoc(_):
+ os.path.join(sys.prefix, 'bin', 'sphinx-apidoc'))
+ subprocess.check_call(
+ [cmd_path, '-o', output_path,
+- os.path.abspath(cur_dir + "/../" + module),
++ os.path.abspath(cur_dir + "/../src/" + module),
+ '--separate', '--force', '--module-first', '--doc-project=API'])
+
+
diff --git a/dev-python/pygccxml/pygccxml-2.4.0.ebuild b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
index f93c64023594..114320ffb31d 100644
--- a/dev-python/pygccxml/pygccxml-2.4.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
python_prepare_all() {
eapply -p0 "${FILESDIR}/${PN}-2.4.0-pyproject.patch"
+ eapply "${FILESDIR}/${PN}-2.4.0-doc.patch"
eapply_user
distutils-r1_python_prepare_all