summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest2
-rw-r--r--dev-python/pygments/pygments-2.18.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 66e15165e40e..cd4bfbe2043d 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,5 @@
DIST pygments-2.17.2.tar.gz 4827772 BLAKE2B 7e6db51ff35ec35981fcdd6f4a1f0a242c29e8b0947a5a3febdee35a0e4047414d49d6883b8fbf9de78b149323f0b3c86b315b03eaada557b4cd70e67917aab8 SHA512 a3408a21f4c0a9f1a81d4fae5c2924f66f1f17daf98a52c4379d6953625354f47bb8db3005e6ab09407627f592843efde12afb14e1271c1e685973eb4c238d89
+DIST pygments-2.18.0.tar.gz 4891905 BLAKE2B 4ff1cc75ca348eecb96ecefe549a1e1c9a9cc81e1829a2354c70ce6f6e538bddbb9b7f90e781bbdd6433cee36e4a99fef9adaef95ca275d1be57a33ed8a77351 SHA512 2f696fed7f2120f9e3bd5f3d2837a5d6b883434b8d0f68d039c2620213508638cedf1517375019809720d56fc52f07e3bddd0defc4707703ace5d707908c00fb
EBUILD pygments-2.17.2.ebuild 1130 BLAKE2B bf3a5062f1978428e050dd557a7d34052e8a37ff20c94b1e1283491e5d40c8e5ae716d1b959ff8fa11d7cf7c9615fdf256d21d24ce76a96d9060526d96b377c7 SHA512 d367afcc8cc10491f57411099f33052e5b55a1b0a036da2f79b94cd41cf1ac330e5df1ec3ed7f7171cae76bd58cc234fa47d469ff2c7962ff4f3bd24c8b41fea
+EBUILD pygments-2.18.0.ebuild 1138 BLAKE2B 5b4c09583d8feef1c1640e9fa4bba152873879c99dd666d6fbff0fca032fb7548c66369e92ea321657004c78d033083a00bfde3c54734589a6c191ef479fcf87 SHA512 1d050663dfe16416e23f17d0ce23e00a22beef604240b0e11e12c3bf22ba44de8d907f406e849fbea6e313e50c31126faaed9972ff09692b213de233ef8f1d44
MISC metadata.xml 618 BLAKE2B fbe7a30ff157e4e13592f96ef8a8b9be60ef2f8e72c08baa56dcca027dde82715b78b3b670ef29190d88dbb582f5cc5fdf9aa2547db5d714c666c28020b54def SHA512 860f398e047e516a8ea4d7fd4e900f1c8efed92422c304e305dc16df9e536ce7be7e06407f93caca0d47f6f929eaa66b2e56acd25105d4f232b841eaca381eb6
diff --git a/dev-python/pygments/pygments-2.18.0.ebuild b/dev-python/pygments/pygments-2.18.0.ebuild
new file mode 100644
index 000000000000..c287a352633e
--- /dev/null
+++ b/dev-python/pygments/pygments-2.18.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 bash-completion-r1 pypi
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+EPYTEST_DESELECT=(
+ # fuzzing tests, very slow
+ tests/test_basic_api.py::test_random_input
+ # incompatibility with python-ctags3, apparently
+ # https://github.com/pygments/pygments/issues/2486
+ tests/test_html_formatter.py::test_ctags
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}