summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest4
-rw-r--r--dev-python/pygments/pygments-2.19.0.ebuild46
-rw-r--r--dev-python/pygments/pygments-2.19.1.ebuild46
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 4914fe8da975..5d6ee5132f3c 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,7 @@
DIST pygments-2.18.0.tar.gz 4891905 BLAKE2B 4ff1cc75ca348eecb96ecefe549a1e1c9a9cc81e1829a2354c70ce6f6e538bddbb9b7f90e781bbdd6433cee36e4a99fef9adaef95ca275d1be57a33ed8a77351 SHA512 2f696fed7f2120f9e3bd5f3d2837a5d6b883434b8d0f68d039c2620213508638cedf1517375019809720d56fc52f07e3bddd0defc4707703ace5d707908c00fb
+DIST pygments-2.19.0.tar.gz 4967733 BLAKE2B 0240b876edc619623f9102ef5d88a1135c9229aa34ce44a7482d6004b3b2618c1d0727bd3a43c056a0b9f745aa3fac73a13eb9875a0cd1338c43482439ba0f74 SHA512 ac7b8c85b54acf65fc4de2202c25a0dfc35daf3ac8eacc9bbae5a07fa0b66bfb5fdedd952b0917773e4f4ce5359854b2e8c4ac368c2137e5b5a794b6f267ea74
+DIST pygments-2.19.1.tar.gz 4968581 BLAKE2B 24bc120c4709af2f313010ed953a446bc29ee32269d47c3325067fea60c2a945376426a7c8d37e8916cc09e0534c2b6e63f69226768d6afd6e88dac875cc4419 SHA512 f8547b1eb032fb4c0ad15f1bb61bc6d8c25b309e61850a7ebe4e879fefe1ebb0acba53192d1294e8ef243613ba546e1e7ac7474ab1b49b1a1c1551c6733d9ec7
EBUILD pygments-2.18.0.ebuild 1124 BLAKE2B ee3e0484b8bc2d3b01f113a2f417f87d06338d3519a66b2182b7a50f893eb6bf63147592d9107a547a95f7346bd711f637575984cb01b4194785c5aaa144e089 SHA512 e89fd6918adfe57e5c5c3b264b2db2aa39c4562bc77e82be1fac213efa3d8d3a705b574730bc2aeafb71b4d5be0bd7bb9353515c3017b60292f14987fb928a19
+EBUILD pygments-2.19.0.ebuild 1132 BLAKE2B 82755fc860a11238c0f8db6ed807309c5c6f7196808b2e1cd532d0328fbe356ce93b3208ba3bf83ed14b6cc447ebb9b0e9710ef92bdcdf16af7cd6f128a762ab SHA512 5c6cb796817fb8cd72b02ee5dcb97576e404a421ae62115d1534dc3deeceb42b8cfb5885f513dae73615bf2b628f3bd743f5c64a86980a41ea8f7f732dc0820e
+EBUILD pygments-2.19.1.ebuild 1132 BLAKE2B 82755fc860a11238c0f8db6ed807309c5c6f7196808b2e1cd532d0328fbe356ce93b3208ba3bf83ed14b6cc447ebb9b0e9710ef92bdcdf16af7cd6f128a762ab SHA512 5c6cb796817fb8cd72b02ee5dcb97576e404a421ae62115d1534dc3deeceb42b8cfb5885f513dae73615bf2b628f3bd743f5c64a86980a41ea8f7f732dc0820e
MISC metadata.xml 618 BLAKE2B fbe7a30ff157e4e13592f96ef8a8b9be60ef2f8e72c08baa56dcca027dde82715b78b3b670ef29190d88dbb582f5cc5fdf9aa2547db5d714c666c28020b54def SHA512 860f398e047e516a8ea4d7fd4e900f1c8efed92422c304e305dc16df9e536ce7be7e06407f93caca0d47f6f929eaa66b2e56acd25105d4f232b841eaca381eb6
diff --git a/dev-python/pygments/pygments-2.19.0.ebuild b/dev-python/pygments/pygments-2.19.0.ebuild
new file mode 100644
index 000000000000..32672a54af5c
--- /dev/null
+++ b/dev-python/pygments/pygments-2.19.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 bash-completion-r1 pypi
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+EPYTEST_DESELECT=(
+ # fuzzing tests, very slow
+ tests/test_basic_api.py::test_random_input
+ # incompatibility with python-ctags3, apparently
+ # https://github.com/pygments/pygments/issues/2486
+ tests/test_html_formatter.py::test_ctags
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}
diff --git a/dev-python/pygments/pygments-2.19.1.ebuild b/dev-python/pygments/pygments-2.19.1.ebuild
new file mode 100644
index 000000000000..32672a54af5c
--- /dev/null
+++ b/dev-python/pygments/pygments-2.19.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 bash-completion-r1 pypi
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+EPYTEST_DESELECT=(
+ # fuzzing tests, very slow
+ tests/test_basic_api.py::test_random_input
+ # incompatibility with python-ctags3, apparently
+ # https://github.com/pygments/pygments/issues/2486
+ tests/test_html_formatter.py::test_ctags
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}