summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt/pyjwt-2.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyjwt/pyjwt-2.7.0.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-2.7.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pyjwt/pyjwt-2.7.0.ebuild b/dev-python/pyjwt/pyjwt-2.7.0.ebuild
deleted file mode 100644
index 13e25fa6279b..000000000000
--- a/dev-python/pyjwt/pyjwt-2.7.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN="PyJWT"
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="
- https://github.com/jpadilla/pyjwt/
- https://pypi.org/project/PyJWT/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- !dev-python/python-jwt
-"
-BDEPEND="
- test? (
- >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "cryptography" dev-python/cryptography
-}