summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-2.11.1.ebuild58
-rw-r--r--dev-python/pylint/pylint-2.12.2.ebuild2
3 files changed, 2 insertions, 62 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 6223d15c8bb3..14e9ba129116 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,6 +1,4 @@
AUX pylint-2.4.4-sphinx-theme.patch 468 BLAKE2B 741a362b51d35f574b245b4df81309b1b08be7a38ca7fd5c04d6c9ce39bc830e32531a29103d1261d9fea6eecf5f52fb1d4cf74ab0ec3bda5f6299e4edfecf94 SHA512 7f1896819d4f2766a83ce2600754d7a698ce13388de9127e83b42b76b332ae5eb54eb538b9dd5d81dafe1cd5798e703c1f3fd7fa318a8582aa7c2c0db7cc7a30
-DIST pylint-2.11.1.gh.tar.gz 967223 BLAKE2B 435bb4589fa6dbfadfa234f8cb968a1d5c39efaf9b37fd20dfadc6feb1e997b34124386dab777b1aa1657bd9a36055d535e231181c71834517528cbbc04c698f SHA512 fe283b6eb8090414ea99809158b4e7f9fe85187ef6488ec37c5f34430793b0b4ff8afd9c97452fe0bb88efb9be001c0fd9f9a09a23081cb79084ae409b277f34
DIST pylint-2.12.2.gh.tar.gz 1032702 BLAKE2B de7dce04159b332baa5c23f4034ee249e49f9239c5c9190213a51a84a47ac2129f8a2265e1ad9c01ab448ec58f4f36653c6de5b0be6bfdf6aa286c8887313759 SHA512 0d2b9b785371af0a1c809271153abbab58f50455b34f12370461ded2c4f3d62656e4c0391adff48e179b95da945a2f44e762863e2b7d63808976bf5f684e20d2
-EBUILD pylint-2.11.1.ebuild 1455 BLAKE2B 58acfc0c54021ddf56ce16cb7788e621807418d4054278ab33852cc41150921b3da2a8851c4a9b7978e839ae85faca611fc5e9c0e8a69007e1d11700d0854abc SHA512 a46543d41dcde85017cbcc8cab08ac8e74c24cd9ec7d6489d33982c9f8233d9dbaed4f231d647c31883200e2ddec7a79dc189243d64091deca1dbc18b4856f0e
-EBUILD pylint-2.12.2.ebuild 1725 BLAKE2B f43be54f1bd55b286a0b94571de2a74ed52999ae803db94bdee3dab79339c4bb9b7d968f503f1cbaf23bac96ad90a129e218405c9d2074f1c62f7665062de32e SHA512 2b12bb303414f561b9e6971b1d1dca74e788d5eca2356732ceb35bb45be89fe9d18e609303ac668acf254bc5ba29c266f2e71869e9b0d758d3b22743a5c669b4
+EBUILD pylint-2.12.2.ebuild 1724 BLAKE2B 289f62e0ad940e80b8b7de06a9ee52d043d4e2f6f16d99fd17f0d97dae0cac9687d960688a622db8159daae22e579c21bdee56c24acd40685a43446a365de22f SHA512 9798ca63f8d988f1a2818e36f059e644372d9a6c8d60dcc34e3042dd8360da75d2b8bfcedbc4b69e9a079b077885595586dc6ddfb41345fb5165847f15655df0
MISC metadata.xml 1100 BLAKE2B 98ac44b343a44471afed50ea76c658142056bba3e3e0a75e7a3854c6e196eb55eeb466611c4d2976787fe4e5d4c13c1f434cad8afaece76f3ba04cd94197906f SHA512 78b52b43ebc944c60d037adb4874fcbe72a2ac713b713ac3b9a226966db2fabf0b31a11e16dcf26243cc19c62841928ac4bb32f5eef69f9d6ef9cb0222362bbf
diff --git a/dev-python/pylint/pylint-2.11.1.ebuild b/dev-python/pylint/pylint-2.11.1.ebuild
deleted file mode 100644
index 5d8bf6a9f5e8..000000000000
--- a/dev-python/pylint/pylint-2.11.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint/"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-2.9[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
- # Specify the test directory explicitly to avoid import file mismatches
- epytest tests
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-2.12.2.ebuild b/dev-python/pylint/pylint-2.12.2.ebuild
index a0daced3712e..21083c4d3e9f 100644
--- a/dev-python/pylint/pylint-2.12.2.ebuild
+++ b/dev-python/pylint/pylint-2.12.2.ebuild
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps