summaryrefslogtreecommitdiff
path: root/dev-python/pymongo/pymongo-4.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymongo/pymongo-4.4.1.ebuild')
-rw-r--r--dev-python/pymongo/pymongo-4.4.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pymongo/pymongo-4.4.1.ebuild b/dev-python/pymongo/pymongo-4.4.1.ebuild
index a371ef783deb..a543900a9665 100644
--- a/dev-python/pymongo/pymongo-4.4.1.ebuild
+++ b/dev-python/pymongo/pymongo-4.4.1.ebuild
@@ -31,8 +31,10 @@ RDEPEND="
kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
"
BDEPEND="
- test-full? (
- >=dev-db/mongodb-2.6.0
+ test? (
+ test-full? (
+ >=dev-db/mongodb-2.6.0
+ )
)
"
@@ -40,7 +42,7 @@ distutils_enable_sphinx doc
distutils_enable_tests unittest
reqcheck() {
- if use test-full; then
+ if use test && use test-full; then
# During the tests, database size reaches 1.5G.
local CHECKREQS_DISK_BUILD=1536M