summaryrefslogtreecommitdiff
path: root/dev-python/pynacl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynacl')
-rw-r--r--dev-python/pynacl/Manifest2
-rw-r--r--dev-python/pynacl/pynacl-1.5.0-r1.ebuild (renamed from dev-python/pynacl/pynacl-1.5.0.ebuild)23
2 files changed, 17 insertions, 8 deletions
diff --git a/dev-python/pynacl/Manifest b/dev-python/pynacl/Manifest
index 8b7942406051..366ecd09b3cd 100644
--- a/dev-python/pynacl/Manifest
+++ b/dev-python/pynacl/Manifest
@@ -1,3 +1,3 @@
DIST pynacl-1.5.0.gh.tar.gz 20350195 BLAKE2B 56ca4f47867cce6e22fdacb0558b5f901aae318b47bacfe5f4ad02d8923e1c86d0a2dd186ec29c820a786ab844d928479fca2d1472a8345b82be6bcbc67c3328 SHA512 905d3a7ce7f758b31a5d34471d5a0202fd2ba3d904a7ec59a158bcd1ea572fc87e29fc144c733d151cbaa48788c939808bc51d00acc973fe6d190eefdd3bfd59
-EBUILD pynacl-1.5.0.ebuild 880 BLAKE2B b3190da3bbf421eec0f084182b333b147b245a52a6727620d6ee9d848949f05b3a9a096ddb66690739a65858ae33d4da285c5cdfecd51ddaf764adda2751a04f SHA512 8fa3fc857cc7e589686352327f199dc1a5310be33723b059b51034ef6c8a1358a6898169a4e419a0bd947bf8296e79a12f33fcee1b16bfc603a9192955373c95
+EBUILD pynacl-1.5.0-r1.ebuild 926 BLAKE2B 8eee61d0c1d3c281d4e1ed8c52e894870f2b86d2249337a24ab15b3124a7f42d1ed1f53894634f6183433f2cb70837a0e75b14b84491477def5ffee50fa9be3b SHA512 4cfb693b5f1d0d8e7df4a8f2ba1c3a38a766cea74bae4653bfa45d2f5f6d4e4b073d796ed701375f2a8481a97fd56d7595395279acc082f0fc97ca25de213637
MISC metadata.xml 674 BLAKE2B 676d246f5dac0a5f34c272e29b742a3a454e0ccef4a1ccecbacdfb652070c81bc145ee3d100f9c5e5ac025c183e80d937a4d9d8c6e0b5f26ac2c8225962681f0 SHA512 b5afb7450c64aace06974d98ce3cb172e2e4d7b343a0bcdf1b34505d3d9e180b774f359de1762a1b15127d23e5808289258e2333ab73f5cde04513015409c1a2
diff --git a/dev-python/pynacl/pynacl-1.5.0.ebuild b/dev-python/pynacl/pynacl-1.5.0-r1.ebuild
index 8c17681dfc74..b108506dab01 100644
--- a/dev-python/pynacl/pynacl-1.5.0.ebuild
+++ b/dev-python/pynacl/pynacl-1.5.0-r1.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
-SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/pyca/pynacl/
+ https://pypi.org/project/PyNaCl/
+"
+SRC_URI="
+ https://github.com/pyca/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,13 +28,15 @@ RDEPEND="
dev-libs/libsodium:0/23
"
BDEPEND="${RDEPEND}
- test? ( >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}] )
+ test? (
+ >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest
-src_prepare() {
+src_compile() {
# For not using the bundled libsodium
- export SODIUM_INSTALL=system
- distutils-r1_src_prepare
+ local -x SODIUM_INSTALL=system
+ distutils-r1_src_compile
}