summaryrefslogtreecommitdiff
path: root/dev-python/pyperclip/pyperclip-1.5.27.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyperclip/pyperclip-1.5.27.ebuild')
-rw-r--r--dev-python/pyperclip/pyperclip-1.5.27.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.5.27.ebuild b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
index 15e303b5c97d..f1298bc162c6 100644
--- a/dev-python/pyperclip/pyperclip-1.5.27.ebuild
+++ b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
@@ -3,8 +3,8 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7)
-inherit distutils-r1
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
+inherit distutils-r1 virtualx
DESCRIPTION="A cross-platform clipboard module for Python."
HOMEPAGE="https://github.com/asweigart/pyperclip"
@@ -13,7 +13,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+RDEPEND="
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_copy_paste.py -vv ||
+ die "Tests fail on ${EPYTHON}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}