summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-fmt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest2
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.0.2.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 38aa6f33aa62..1aa688f0f552 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,3 +1,5 @@
DIST pyproject_fmt-1.8.0.tar.gz 16696 BLAKE2B 1614fd6da4bb7be818825138b69b826b7141ae0fcada4414daa54b1c883ec3bbdbe95377155869d0c393b1b9646b69ebb009fe47f1c530b1f1c9f02c8ba8f57d SHA512 0731ffbe514cf8788bf1cfcca506591fefce3b98b1c6d014a8e17825ab6c73edc4ad8e7214cd8f6fc9124ed2ff362d03b328d47e96a6246165b4dd9fdd68299f
+DIST pyproject_fmt-2.0.2.tar.gz 8647 BLAKE2B aae92d952883adce7ee6bd92a29517064dfd25ed6a90ca4543ec4093ce57bb17d2315134d5709d084e17098680a861014fc35d18feeac17ba9c9cca4d501959a SHA512 750f8006a30425ccfcd28909f06208344776a250698025f7f1c8a33d7316e4dfe9f06baea6050848691940846ea1ef3dfdd1a7878c72bb611f1a6b9b2bed3ff7
EBUILD pyproject-fmt-1.8.0.ebuild 1037 BLAKE2B 120635fc4b4c78fdb6b15bf12f809ac4995b21cf8b94f2e24aac3de1954e4be196194488d30c1f63dd07f879dac062c01f38cbc64a2a9270692523eaf0fedde4 SHA512 02712a401d49dadcca45255119759a3a86d0eb2bbb01e30c950d223cd4da80f8a6d38327fd0a9f9993785aec0fc8a21e0a8ad83ac567b1ffed39cea4173d4e55
+EBUILD pyproject-fmt-2.0.2.ebuild 722 BLAKE2B 4502faff8949fb8fe73e07f610aaf135519c915b6631d14c2023fad1af39741d8b32d5c90252208b5041ab0e82b19513ad9e731d34b9212599b67f47620c0b04 SHA512 8c3d7b8b81a36f385d62952bdb14278f41d3cb608e8f9871fd79be90c49acb7601a617857d3d51b7809fa807de7246c8e2d5b06663a703ac4c7447aa0184f504
MISC metadata.xml 380 BLAKE2B f139b3f6c22d40d7c91b9b35db262813e299d1a3c1a1f8d6129e457fac62e3e7029a05315a3bddd9c4542764a33160c89b58b3b62f457efb088a7ae7cd86a936 SHA512 38bd0633defb67ee1831480c8b3896e158d0735ec74057b13b3c389cf26bd6ecb878f21d172f83293789d81ca2c30afedab8eaeb4ab1774b39972fdd5f805a81
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.0.2.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.0.2.ebuild
new file mode 100644
index 000000000000..311a11645a67
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-fmt-rust-1.0.1[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest