summaryrefslogtreecommitdiff
path: root/dev-python/pypy/pypy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy/pypy-9999.ebuild')
-rw-r--r--dev-python/pypy/pypy-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index c0bc0a26454b..11f050a7d0a6 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -232,9 +232,20 @@ src_compile() {
src_test() {
# (unset)
- local -x PYTHONDONTWRITEBYTECODE
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ local ignored_tests=(
+ # network
+ --ignore=lib-python/2.7/test/test_urllibnet.py
+ --ignore=lib-python/2.7/test/test_urllib2net.py
+ # lots of free space
+ --ignore=lib-python/2.7/test/test_zipfile64.py
+ # no module named 'worker' -- a lot
+ --ignore=lib-python/2.7/test/test_xpickle.py
+ )
- ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
+ ./pypy-c ./pypy/test_all.py --pypy=./pypy-c -vv \
+ "${ignored_tests[@]}" lib-python || die
}
src_install() {