summaryrefslogtreecommitdiff
path: root/dev-python/pyqt5
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyqt5')
-rw-r--r--dev-python/pyqt5/Manifest4
-rw-r--r--dev-python/pyqt5/metadata.xml1
-rw-r--r--dev-python/pyqt5/pyqt5-5.15.11.ebuild10
3 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/pyqt5/Manifest b/dev-python/pyqt5/Manifest
index 9399cf1eb252..c258335c7d1b 100644
--- a/dev-python/pyqt5/Manifest
+++ b/dev-python/pyqt5/Manifest
@@ -1,3 +1,3 @@
DIST PyQt5-5.15.11.tar.gz 3216775 BLAKE2B 5bc6cb12b8189ec0767be891971a9fd35109236eb4753eb77940104b71bbf78db4ed2354c54adf5d45655a8ded1cb10033afc037d8a3604c5db3ea073d394e0c SHA512 e52ca215f65dbb035deff042112e26be38b77405a45caebdae3e626ffe6487c88c97c54bfa33cc83d96537daa82b67b7a1c621696538e154e5996714fc063a92
-EBUILD pyqt5-5.15.11.ebuild 5269 BLAKE2B 0e7aef6a453dbaff8d7e0ebdd9f31bdd4335bcdaa360aad71e47577a3942678c597c6470a939a6f0f0b4258a8a5d7ec8e0740ed5706380c3f2c63649542de759 SHA512 e11d867174ab3cfb9bca41fef87e8f8b4bd4e6034f45c6a305bab523d2410096560f55ba7d8207257aa3771c4878305e2ce9aea7f0a0129566d6810ad6ce8d81
-MISC metadata.xml 2287 BLAKE2B b4090aa2c55d05554a152bc3adfa76c68dc78175d26bb4ea6d25858ce2db922c168cc4ded6c7fa9114cf651417e0a6e435baebe460c8efbbd94be17adafd6f43 SHA512 12e3559ff04c32ebce2a382bf3b01730b0b69829c77cdf75f0061143cc19000e126daebbf9014beeae8bd1fba2675ef2ecfe7943296a8dc66000439c104c1351
+EBUILD pyqt5-5.15.11.ebuild 5230 BLAKE2B ec125129b253609be71a804d5347eb0d6e02fdd25f4d564c9ef3a16e4778704b0f536a84458c87fc6cedfacc3d99f3048ad86deceaf23eb3403ba9930088a9dd SHA512 226beaa34b57f91dfdda377e7f3660b7eb30ff32fc132c761e94c28a0a52cc01c10b91f893aea38fee0a86cb6600026259ed1115f0b95f5e23531fe6195a4e17
+MISC metadata.xml 2213 BLAKE2B 5757cf6641335b6d350ec07d124373315ccd6ecd3fde2e89a01e82c510056e32ea996cc3a024fa3dbb899b80ee3e13a0134f88a07ff0ad492a3abf283306d727 SHA512 e84671896ee8b38a2929c732c82456f85d397c5f26a2c02131936bd0bd1685a88921d0aeba9cf56f4d716a17564bd1d4da944762e3997e8a3ce4427aa69ae116
diff --git a/dev-python/pyqt5/metadata.xml b/dev-python/pyqt5/metadata.xml
index 638d81c8245b..d977463b08cd 100644
--- a/dev-python/pyqt5/metadata.xml
+++ b/dev-python/pyqt5/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo Qt Project</name>
</maintainer>
<use>
- <flag name="bluetooth">Build bindings for the QtBluetooth module</flag>
<flag name="dbus">Build bindings for the QtDBus module</flag>
<flag name="declarative">Build bindings for the QtQml and QtQuick modules and enable the qmlscene plugin</flag>
<flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
diff --git a/dev-python/pyqt5/pyqt5-5.15.11.ebuild b/dev-python/pyqt5/pyqt5-5.15.11.ebuild
index c5ce7c2a95ca..3831dd67fac7 100644
--- a/dev-python/pyqt5/pyqt5-5.15.11.ebuild
+++ b/dev-python/pyqt5/pyqt5-5.15.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
IUSE="
- bluetooth dbus debug declarative designer examples gles2-only gui help location
+ dbus debug declarative designer examples gles2-only gui help location
multimedia network opengl positioning printsupport sensors serialport speech
sql +ssl svg testlib webchannel websockets widgets x11extras xmlpatterns
"
@@ -27,7 +27,6 @@ IUSE="
# The requirements below were extracted from the qmake_QT declarations
# in project.py and from the output of 'grep -r "%Import " ${S}/sip'
REQUIRED_USE="
- bluetooth? ( gui )
declarative? ( gui network )
designer? ( widgets )
help? ( gui widgets )
@@ -53,7 +52,6 @@ QT_PV="5.15:5"
DEPEND="
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtxml-${QT_PV}
- bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
>=dev-qt/qtdbus-${QT_PV}
@@ -125,7 +123,6 @@ python_configure_all() {
--enable=pyrcc
--enable=Qt
--enable=QtCore
- $(pyqt_use_enable bluetooth QtBluetooth)
$(pyqt_use_enable dbus QtDBus)
$(pyqt_use_enable declarative QtQml QtQuick \
$(usev widgets QtQuickWidgets))
@@ -153,6 +150,9 @@ python_configure_all() {
--enable=QtXml
$(pyqt_use_enable xmlpatterns QtXmlPatterns)
+ # no longer supported in Gentoo for PyQt5, use PyQt6
+ --disable=QtBluetooth
+
$(usev debug '--debug --qml-debug --tracing')
$(usev !dbus --no-dbus-python)