summaryrefslogtreecommitdiff
path: root/dev-python/pyquery/pyquery-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyquery/pyquery-2.0.0.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-2.0.0.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/pyquery/pyquery-2.0.0.ebuild b/dev-python/pyquery/pyquery-2.0.0.ebuild
index 71f035f16a3d..a72d907f5f71 100644
--- a/dev-python/pyquery/pyquery-2.0.0.ebuild
+++ b/dev-python/pyquery/pyquery-2.0.0.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-# No 3.12 yet for https://github.com/gawel/pyquery/issues/249
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature pypi
@@ -35,10 +34,25 @@ DEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # needs network
- tests/test_pyquery.py::TestWebScrappingEncoding::test_get
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # needs network
+ tests/test_pyquery.py::TestWebScrappingEncoding::test_get
+ # known breakage, can't do much about it unless we force old
+ # libxml2 for everyone, sigh
+ # https://github.com/gawel/pyquery/issues/248
+ tests/test_pyquery.py::TestXMLNamespace::test_selector_html
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # doctest failing because of changed repr()
+ # https://github.com/gawel/pyquery/issues/249
+ pyquery/pyquery.py::pyquery.pyquery.PyQuery.serialize_dict
+ )
+ fi
+
+ epytest
+}
pkg_postinst() {
optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup4