summaryrefslogtreecommitdiff
path: root/dev-python/pysaml2/pysaml2-4.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysaml2/pysaml2-4.5.0.ebuild')
-rw-r--r--dev-python/pysaml2/pysaml2-4.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pysaml2/pysaml2-4.5.0.ebuild b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
new file mode 100644
index 000000000000..1f49c06382aa
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-4.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+PATCHES=(
+
+)
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"