summaryrefslogtreecommitdiff
path: root/dev-python/pystache/pystache-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pystache/pystache-0.6.1.ebuild')
-rw-r--r--dev-python/pystache/pystache-0.6.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pystache/pystache-0.6.1.ebuild b/dev-python/pystache/pystache-0.6.1.ebuild
deleted file mode 100644
index 228eb980f8e3..000000000000
--- a/dev-python/pystache/pystache-0.6.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Updated Python implementation of Mustache templating framework"
-HOMEPAGE="
- https://github.com/PennyDreadfulMTG/pystache/
- https://pypi.org/project/pystache/
-"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="
- https://github.com/PennyDreadfulMTG/pystache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- pystache-test || die "Test failed with ${EPYTHON}"
-}