summaryrefslogtreecommitdiff
path: root/dev-python/pytest-arraydiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-arraydiff')
-rw-r--r--dev-python/pytest-arraydiff/Manifest3
-rw-r--r--dev-python/pytest-arraydiff/metadata.xml15
-rw-r--r--dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-arraydiff/Manifest b/dev-python/pytest-arraydiff/Manifest
new file mode 100644
index 000000000000..98fd302d99d9
--- /dev/null
+++ b/dev-python/pytest-arraydiff/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-arraydiff-0.1.tar.gz 8752 SHA256 4ca5aaa9a8dc55f0cf621ce6cca3060e320e32b1a500e2f87298ade0a5ece7e1 SHA512 321ea04ea7165753cb4d9aff3870d5297f78a0e5ddaf16aecd5dce622f061a2f664479bf8e3af1c7575e968fa66828ed2d0489473e7d8a236c07d1a31adfce5d WHIRLPOOL 08a7fdaa72717d7657ebaa97130aa34096aa0b3cc1ec5a1b507e103441e6991f22f732075416a51a8a34773619a75a3fcc451018f439d986eee5e9e8628c62ea
+EBUILD pytest-arraydiff-0.1.ebuild 645 SHA256 6bc6c4e0fabd5ea9f06a477238f31a2f760e5576b92b8a0405430ea678c6c55d SHA512 88cd6df1f21257b6a92f235068ee508501014149bff17207c0a4d2a54c3b3920a176f4d03a49c94206d1eec6f1bcd06f3e97dbf7aa3108e828750a006d0372e5 WHIRLPOOL 069aa5147d2232b97a093014289f451cdf0391f638661dd6b7c9f4bf8c12933b945a59e3861071bd49bc999db8d5070ddb38d725dc8723eb44119b0f3a8bf407
+MISC metadata.xml 527 SHA256 b14e2f6441966c16f8c9abf3a08f00f0d8ac3e178f2cc680fb3214c2c8cda9fb SHA512 9138033364e009d0bef6499aa1f5353a72033955df26a26869038783bf847c91e8ebdc1b62908e393c4471285420ddeb01118aff5905227b67aeb924bdf2738c WHIRLPOOL 367a22ca731005b3e5dc7443d93fc71120e0c57a7b550e1d45ae963f56cd6b4aacb3dda07a97e64a44aaaaa25b6e8b2ab2f8a1fa21be10aa01fa27d2481211bc
diff --git a/dev-python/pytest-arraydiff/metadata.xml b/dev-python/pytest-arraydiff/metadata.xml
new file mode 100644
index 000000000000..a5905e0e3a81
--- /dev/null
+++ b/dev-python/pytest-arraydiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-arraydiff</remote-id>
+ <remote-id type="github">astrofrog/pytest-arraydiff</remote-id>
+ </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a plugin to faciliate image comparison for numpy arrays in Pytest.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
new file mode 100644
index 000000000000..4220d94ae372
--- /dev/null
+++ b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to facilitate comparison of arrays"
+HOMEPAGE="https://github.com/astrofrog/pytest-arraydiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"