summaryrefslogtreecommitdiff
path: root/dev-python/pytest-html/pytest-html-1.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-html/pytest-html-1.16.0.ebuild')
-rw-r--r--dev-python/pytest-html/pytest-html-1.16.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-html/pytest-html-1.16.0.ebuild b/dev-python/pytest-html/pytest-html-1.16.0.ebuild
new file mode 100644
index 000000000000..339c47814df8
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-1.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Lots of test failures...
+RESTRICT="test"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}