summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest2
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index aa941b8e5373..2ae1de7264f0 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,3 +1,5 @@
DIST pytest-localserver-0.8.1.tar.gz 29088 BLAKE2B 9872d9992a7a19af03bfd7fe748c42cee1daaf7789d4984582c901471eaeab7f1bcf5c21f8eed364c71805fe776f1e4053c6044cd00c333d213ef523b6d0bac4 SHA512 d0707d70b3c5caf346c7461cfca203f903277458596839cc2b1d1d48b6d1e6252e51ebcb9c21dc28fd3b98ce8368cb38e771c2a4226a5fc1dec4007f0b243cc2
+DIST pytest_localserver-0.9.0.tar.gz 30222 BLAKE2B b452ef71045c8a157035d56a17f1debee15ee63ca3912d44c90e691b744216a2375980f728bb1d33ee41c527c7115ea975299d7d567b23a1ca1c5ce2dcf41dd7 SHA512 15aa2db9d5a9ca841499d455de7002cd2cb6288c165605f44bb88d5ce3e06b9ce02eacd226853734017fe41075e1cfcdd5cd5c422ee240086ef0cf95fc450011
EBUILD pytest-localserver-0.8.1.ebuild 961 BLAKE2B f84c535b3f28b7247537f9207ff3cc44899d31d1f33ecf37cf7013800d6ae8cdf3c40374af7cd8969e118b06db44fdf7473821b89f25855a56334f3b263e817d SHA512 1d737b46cfd770d387d261d57ada091e33f2f177d310a4d0603e75de5d342ede176f8ec4ba3508bc2a57dece16d3359a18511bbc54d6a29532891edfd316dcde
+EBUILD pytest-localserver-0.9.0.ebuild 949 BLAKE2B bc762b553715bc4fd9058a067cd2210650c7422de5ee28f033f1803a39ffacde21aeb4809aedd15c4f930451b90fc1272db6e8972e91d2c371c5bd3b5ab2bf1e SHA512 d415f9f2e0cd3963fb3a5e34ffad55fb981b001069e887870a4c626e704c2c641dc0ac8ae6afa282b838d5540a554d56225300af05e377b28cbcbd1f66955d6e
MISC metadata.xml 415 BLAKE2B e9793de9ce60bde1549abb0983ca145f55261653324785d735c91785a20b61d949c228528faa742d669d52c1f456a36c65a93c1e9a692ec9297d4ffcfc0123fe SHA512 e0e7819a4b1bd41301824727b2204092986ba4d0c56fe1530b40543fcf7b90541933a7b8094f24a0573854b76b9ce11b7b42d2e38d135f61fed9b498f05f98e1
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild
new file mode 100644
index 000000000000..4b5bc4f214e2
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}