summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-2.0.0.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-2.0.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild b/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
index 9f85be239d87..045b6a938e82 100644
--- a/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -24,6 +24,10 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/pytest-mock-2.0.0-warnings.patch
+)
+
src_prepare() {
if has_version dev-python/mock; then
# test fails when standalone mock is installed