summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock/pytest-mock-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-3.1.0.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.1.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.1.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.1.0.ebuild
index b5ce25c092dc..0c137d01ff10 100644
--- a/dev-python/pytest-mock/pytest-mock-3.1.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -14,15 +14,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
IUSE=""
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/pytest-mock-3.1.0-warnings.patch
+)
+
src_prepare() {
if has_version dev-python/mock; then
# test fails when standalone mock is installed