summaryrefslogtreecommitdiff
path: root/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild')
-rw-r--r--dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild b/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
deleted file mode 100644
index caf8e246daee..000000000000
--- a/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Simple pytest plugin to look for regex in Exceptions"
-HOMEPAGE="https://github.com/Walkman/pytest_raisesregexp"
-SRC_URI="https://github.com/kissgyorgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-CDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${CDEPEND} )
-"
-RDEPEND="
- ${CDEPEND}
- dev-python/py[${PYTHON_USEDEP}]
-"
-
-python_test() {
- distutils_install_for_testing
- ${PYTHON} -m pytest || die "Tests failed under ${EPYTHON}"
-}