summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild
new file mode 100644
index 000000000000..62e6ee981bda
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-9.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="https://pypi.org/project/pytest-rerunfailures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+BDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest