summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild
new file mode 100644
index 000000000000..0b2a9d9edb91
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.2.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-shutil/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}