summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subprocess
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-subprocess')
-rw-r--r--dev-python/pytest-subprocess/Manifest2
-rw-r--r--dev-python/pytest-subprocess/pytest-subprocess-1.5.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-subprocess/Manifest b/dev-python/pytest-subprocess/Manifest
index f075e21d4e7f..b51dcef1fc25 100644
--- a/dev-python/pytest-subprocess/Manifest
+++ b/dev-python/pytest-subprocess/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subprocess-1.5.2.gh.tar.gz 35438 BLAKE2B bbc92d99dfdd094e8295df37dd3fb66a022ebd4d711bb3f80408d21c8dbe3304bdafd8e7b0fcba15c681b8598bb55f92e0e91e9bd837ca165e94b791ef02c4e3 SHA512 56bf95ee085e74df1b9691d23a1e766de304896a74fb319df22dbb3faa6e4959fe9b7e790cd65a55c816fb39f3ae8db68bd501aeaade0db498a7273cd7267e45
+DIST pytest-subprocess-1.5.3.gh.tar.gz 36830 BLAKE2B 5bd696971ebf97722e0d5712ec57e8642e32187d22b91630c38f0945fc2b1ae35697c22efa4a8104406306482a2231dbe063c4607ed4c616cc3a564bb4b141fd SHA512 639195fdc77ed27efcc7fd7557cadd4f631b81de640754a4b4bcfbc0a9cc6f13efa3b4c38a59a49b594b9cc84baf1cfa97cf1a19e9be7ab7888854cf0057d355
EBUILD pytest-subprocess-1.5.2.ebuild 1097 BLAKE2B 195f0a1749e42967f1bdc4b1c548ede44c740c16d7e3c24befd35f849a52e54cc81acd4c25265a0850db896ce987d1437da88b6f65fade8be0a085cbe33a2562 SHA512 76910107c3730a235982e413b2a3201adede00fa33e9e96a47e83b4b1188c4673404cf088a8094ce4d8b941dcb6f40ae710bca0ce4bc6841ebf53fac65bee459
+EBUILD pytest-subprocess-1.5.3.ebuild 1105 BLAKE2B e54c3354ea02411261c59c4d40c9aea40718dab0555aa21795ed0d9ab1c952f1b08f099932dc63d570a5e4f5f2ad7182e3ae8b52c9ba8fc3aea795af37385f1e SHA512 67ba534fda70b0e1b3f0d9327d4f80d209092959f825e6ebf732f2a8c67ad9077df867cd874b88d4d88cdffcf42f11d9e60de2de680d0479d44825cf84c8f200
MISC metadata.xml 390 BLAKE2B a3bc770c204c31105ed2d53ab7ff74679fa2738e4cb422a17157e88c7f1bdc061af21e238fb63fcf32982ba3b60fd7ea51678dd594ec03befc1d41db48663004 SHA512 664188e01242f89a25192355de77622ddf6d1448a65f665515a7294754f0bae30dfa63baa03104759d93e9c1800471fa579ee11b8fe4ce1229cce400fffe9f89
diff --git a/dev-python/pytest-subprocess/pytest-subprocess-1.5.3.ebuild b/dev-python/pytest-subprocess/pytest-subprocess-1.5.3.ebuild
new file mode 100644
index 000000000000..eb021c3db5f3
--- /dev/null
+++ b/dev-python/pytest-subprocess/pytest-subprocess-1.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin to fake subprocess for pytest"
+HOMEPAGE="
+ https://github.com/aklajnert/pytest-subprocess/
+ https://pypi.org/project/pytest-subprocess/
+"
+SRC_URI="
+ https://github.com/aklajnert/pytest-subprocess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_subprocess.fixtures,pytest_asyncio.plugin
+ epytest -p rerunfailures
+}