summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 605ca46a806b..b61b9ed658ee 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,4 +1,6 @@
AUX pytest-xdist-2.2.0-services-conflict.patch 1097 BLAKE2B edc3ecb79578f89e9ce5515e194dc16df34abc2685d9fb78cc5930f29893dbd9e145c95e5b1f58bf252710c57964ea00dc8b71e20fd0aa713e9b9ab2d8d29a93 SHA512 50155aa39d0a87be7a22d0ccf6c9d8eacc8ce4342baa3fd67839b3c5b4d05b31fef5786a60e15051de3000b3ee3494ddb48feba43850d677484e239ee4be8b02
DIST pytest-xdist-2.2.1.tar.gz 64956 BLAKE2B 7ea18b0e7893000ed9d8718506a7b0f7cf45444196a23e3defec34639c2159b52c7a533ddbc0e0a9b3c3f1e0a867ad5c85e3549167e9b7049ce718646ed50717 SHA512 0732f5ffb56eead3d1aeecd37381c2d9c6ed22398e8e51e9358b562765d737ebde48ecb6fe9f90d9a46902dba1422721cb2c7bfc9fc13918aa2c3b8e6a5e48c4
+DIST pytest-xdist-2.3.0.tar.gz 66072 BLAKE2B 367ff15cd46b8594668ccd9710a2fc7665295d41e268b464b81d5e740a580d70621a1ab5ab590788e44887b7aa3049a83853ea097c0cff54e22c3422c8f11b24 SHA512 bf49a1684b29f0ae21621b9d293f530cf2fa3d88b33f631fb803aef872c0d5ef6b3bbf2e16d01be8a6c1872fe3e6cff86ab842e3000b9e642fb46c2a170627f6
EBUILD pytest-xdist-2.2.1.ebuild 924 BLAKE2B f6dc3fb9beede5a58e7d1ca112435f287b226bd78326bfd6ab2c6b74377da6770d462d4f7817ae9888ad756f43581146721e55be798f8e6fd41895311ca0805c SHA512 214b7fa4672bc009b6f5c5176f26912c888d5a5dd895cb0c100c3bfa11cc827dd093d2b7026cc456dc325caeb9464da1e4deeba1634fb732dccc72de78098125
+EBUILD pytest-xdist-2.3.0.ebuild 932 BLAKE2B 9e5421027442ea79ce82395adc2221cd97c9a84fe7e05e81cb678029a3c4b6c56fa23fd83749413729cb60ff78d1bd47cbe8f133606e1e4b43b2e693fbf1e430 SHA512 7cd7fd85edfc39ee9e1328066fb6f6a33642a0efaf8f0da663910b420b59d12dc5e404794b06eaf16c54cb4741340679a3cd6f961516fad3fd2cadd26a898934
MISC metadata.xml 402 BLAKE2B 9e24660b4146f94ecdf375e3bd89a9ab01157ab7c7e9b37fa183eaad12edfbb6574ecef4a98e6079b3dd81e6614b5eb23b0bfd69c9468abde7bbc073e8ef44b4 SHA512 7fbab209b81bba0684b9dad109dc7ba64f9c496e5ad69fcbc659f9361aa131f6779a5419a54112b4ff1c2a63a9deef5f36791551165b1b4b7219c7a00fe93060
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
new file mode 100644
index 000000000000..127050a2150e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest