summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest2
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.7.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index f93b32e1637d..15922495530a 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,5 @@
DIST python-cinderclient-9.6.0.tar.gz 237239 BLAKE2B 34080bcc739db3df9fbf2b45115726df6c435ade39b9d92b8752db06a661db8d6ad92005d1358ae4f0bb313db663bbb1e6e7fc1fde0373941eee39921b22a9b3 SHA512 f2dec3927063c40046c72e090f95f996a16582c09cca8de320fedf80037e4c8dea231c8b48d3fc1ad085b89f43afc413c477e162f231940616f3373d4f86d4ee
+DIST python_cinderclient-9.7.0.tar.gz 236901 BLAKE2B 9cf188fd8960a99dfee68ec943b0e4124a78c2a8d9bc990f8bbe98646886e462e3bdd3449772492d07a1d8697423f57ae06d55daba5ce2ac44205407dc554d3b SHA512 b1a0222b7d67cda221086c469f76dc757905ca2b92645389603b0ba28c1a6b5eedd0049dbc09b6da1fc097e4ab7826c11927c88cf7c314757cdde1826cf55d1c
EBUILD python-cinderclient-9.6.0.ebuild 1272 BLAKE2B d4d0969e69b83e3a539ec432e1768fe6f5f4941fead678b43b1635f01b9da7efe011a1bd323683c2fedd424ca88bf82d050fb900bda01c9eb5cd5e6fab37ad2a SHA512 d894f2d437662a8f7674fa3c8c98059af426660666253944d8aaf75d0521c2097fb3d2f5631358c403d5387158e81b30fb1007adc0ca3cbb75c88c9ac689b45c
+EBUILD python-cinderclient-9.7.0.ebuild 1255 BLAKE2B 2eac62128c6aa9ac26ab58f39a9cd45b4decab3b2a5f69fbd7be28b78e816f0b60dff7a86e9603bb9ddd0c4e323bda4ef5a645b42d35640c106f1a3a8f941279 SHA512 ced88c042db4a85a5ce1a5151aaa2dc99830c5af6e7a07a786fc7da5a14686986016e9e55faca9c0a859239edaa4790f8d5ccfdb5e1fa6334daaa846ef887985
MISC metadata.xml 727 BLAKE2B 0017cc08edf25f27b8a2816bc3ce1374148a17522bf2c5ea643ad10cde9f5779b1b6bf1e3c91627db76d2f77b8dcbfc87a29fb2cdd8064b3140fb14d1e6e00a1 SHA512 e30e64371f7a5f5fa506396f2edbbc7f862a585c7fe9af4f6fe63e99d4bbe9f9bf3a1f002a62c40ab9d75bd90ab99446bb80bf7f2fedf5b37287eeb54e5dacbe
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.7.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.7.0.ebuild
new file mode 100644
index 000000000000..e30e56b5a3bc
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-cinderclient/
+ https://github.com/openstack/python-cinderclient/
+ https://pypi.org/project/python-cinderclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-5.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}