summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest2
-rw-r--r--dev-python/python-engineio/python-engineio-4.10.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 776e6a3045e5..e0de6d5d1747 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,5 +1,7 @@
DIST python-engineio-4.10.0.gh.tar.gz 317108 BLAKE2B 3089722ab6f398144c5a87db1056cc9f569ba562ceafdb674390489103ee105f2eff138ad5b9f656088a81b7560225622a79849feb11003bc76b8541aa2ba41d SHA512 349c244edf8d6bc0294a4db2c98b3123ce44c152eaa085f9cc048dbbf2a472383bafdd321eb83f84a298fe6e3aa15ae9ce79b5d0753b80441dcd57f6692a018f
+DIST python-engineio-4.10.1.gh.tar.gz 317153 BLAKE2B 3e75591bc79bc705dd844283485e7087a97a5493a1a8db0095bbbb2935de60deba394fae2f0136167692170ab5dc21713a7683819f49528f8912c58d9d9b51ca SHA512 6fa6828803143579564b89c6ba121dd3430d884e09eff2d2a0f9018056b2c88a0b7ecaa792ff5d1d12c86fabaf48d171af266ca9a0e9aee9cee80dc02af06210
DIST python-engineio-4.9.1.gh.tar.gz 317721 BLAKE2B b776a56993f6dafe1778be93dbc507eb5ae96e44f0635b17fb3592fb9fca49c0a338393a128e05089a846b43f41328d788066f0b7a0edad78c88e3b14d6adec9 SHA512 1414d30fa3073124936909e1395e27579eea2b27862a9770b78c8d91b5568aff869e84f9477c7225cbe35462849445ce9ab17b8ca7b6e8aadeafcdebcb26df0b
EBUILD python-engineio-4.10.0.ebuild 1498 BLAKE2B e2ef9f9cbe9728ac6332bce49e8c7bb69e6e25b7ec90dc45b5ed30adba6916441ef9954510439cd0b93b89bdfe2672f6126ce99dc81f45346af7a4d0a7554a67 SHA512 95b5631ab26356a54b12b11bfe6566004efe3871e9cadbda9e33c44bf477a355fd3a3587011bc223b8930ff0a0d1711c612c95669b4142d22edb1e1f8838a7aa
+EBUILD python-engineio-4.10.1.ebuild 1498 BLAKE2B e2ef9f9cbe9728ac6332bce49e8c7bb69e6e25b7ec90dc45b5ed30adba6916441ef9954510439cd0b93b89bdfe2672f6126ce99dc81f45346af7a4d0a7554a67 SHA512 95b5631ab26356a54b12b11bfe6566004efe3871e9cadbda9e33c44bf477a355fd3a3587011bc223b8930ff0a0d1711c612c95669b4142d22edb1e1f8838a7aa
EBUILD python-engineio-4.9.1.ebuild 1498 BLAKE2B e2ef9f9cbe9728ac6332bce49e8c7bb69e6e25b7ec90dc45b5ed30adba6916441ef9954510439cd0b93b89bdfe2672f6126ce99dc81f45346af7a4d0a7554a67 SHA512 95b5631ab26356a54b12b11bfe6566004efe3871e9cadbda9e33c44bf477a355fd3a3587011bc223b8930ff0a0d1711c612c95669b4142d22edb1e1f8838a7aa
MISC metadata.xml 518 BLAKE2B 7325d24cc26b1a3b4e2dec04159cdd4ebcceaf0384fccbee11205f9c000b1e9f84f97c742a6181dbad419e2527c6f874bc3f89760daa6b6dd2feb9b1f874b515 SHA512 40fe9ac96224019d28206f75ae6249c75dbcb759918c03826af4f8a394586bd5df445ef475cd009e8af93ea5c7424abebbbfd65ac2e2eb7bdd9e8a29f2dcb34f
diff --git a/dev-python/python-engineio/python-engineio-4.10.1.ebuild b/dev-python/python-engineio/python-engineio-4.10.1.ebuild
new file mode 100644
index 000000000000..1112128be5ae
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.10.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/simple-websocket-0.10.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}