summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest4
-rw-r--r--dev-python/python-engineio/python-engineio-4.9.0.ebuild59
-rw-r--r--dev-python/python-engineio/python-engineio-4.9.1.ebuild2
3 files changed, 2 insertions, 63 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 40f16a1fbf8f..8c56f3018396 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,5 +1,3 @@
-DIST python-engineio-4.9.0.gh.tar.gz 314185 BLAKE2B e14bb11f5762c42a77d782b0e1ce20c30f0f5599ba0c4577699d53f085464ce588660805d1b8c18a147b3bf01a2e255980f21e36003127e17351c28bd42f433e SHA512 24838cb71ca3beda6a28deaa37208fae0e673bb0a00696594aa638af95e49af479b0088809f093ace9b2a8f5f7a4dcc95bbd2aa5c97938137b6e594ac1a7950d
DIST python-engineio-4.9.1.gh.tar.gz 317721 BLAKE2B b776a56993f6dafe1778be93dbc507eb5ae96e44f0635b17fb3592fb9fca49c0a338393a128e05089a846b43f41328d788066f0b7a0edad78c88e3b14d6adec9 SHA512 1414d30fa3073124936909e1395e27579eea2b27862a9770b78c8d91b5568aff869e84f9477c7225cbe35462849445ce9ab17b8ca7b6e8aadeafcdebcb26df0b
-EBUILD python-engineio-4.9.0.ebuild 1498 BLAKE2B 71a53a7f70eaf38c6fe37df3637d2c6526368a2c1df222fcddbd2dbe19e24543195cb8e9f9578483d014a178c3ae13cbdcf231b9f66a16db03864f665d9507d4 SHA512 69e50125d4b051d3a2ebec2e767b8e1848b57e5cf22e6eeac14ef92508e3828da99c05496e34bcf1cff57703c0bba20d503f7b638b0896232dd5d77fddab18ed
-EBUILD python-engineio-4.9.1.ebuild 1498 BLAKE2B 71a53a7f70eaf38c6fe37df3637d2c6526368a2c1df222fcddbd2dbe19e24543195cb8e9f9578483d014a178c3ae13cbdcf231b9f66a16db03864f665d9507d4 SHA512 69e50125d4b051d3a2ebec2e767b8e1848b57e5cf22e6eeac14ef92508e3828da99c05496e34bcf1cff57703c0bba20d503f7b638b0896232dd5d77fddab18ed
+EBUILD python-engineio-4.9.1.ebuild 1498 BLAKE2B e2ef9f9cbe9728ac6332bce49e8c7bb69e6e25b7ec90dc45b5ed30adba6916441ef9954510439cd0b93b89bdfe2672f6126ce99dc81f45346af7a4d0a7554a67 SHA512 95b5631ab26356a54b12b11bfe6566004efe3871e9cadbda9e33c44bf477a355fd3a3587011bc223b8930ff0a0d1711c612c95669b4142d22edb1e1f8838a7aa
MISC metadata.xml 518 BLAKE2B 7325d24cc26b1a3b4e2dec04159cdd4ebcceaf0384fccbee11205f9c000b1e9f84f97c742a6181dbad419e2527c6f874bc3f89760daa6b6dd2feb9b1f874b515 SHA512 40fe9ac96224019d28206f75ae6249c75dbcb759918c03826af4f8a394586bd5df445ef475cd009e8af93ea5c7424abebbbfd65ac2e2eb7bdd9e8a29f2dcb34f
diff --git a/dev-python/python-engineio/python-engineio-4.9.0.ebuild b/dev-python/python-engineio/python-engineio-4.9.0.ebuild
deleted file mode 100644
index bc862843428a..000000000000
--- a/dev-python/python-engineio/python-engineio-4.9.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Engine.IO realtime server"
-HOMEPAGE="
- https://python-engineio.readthedocs.io/
- https://github.com/miguelgrinberg/python-engineio/
- https://pypi.org/project/python-engineio/"
-SRC_URI="
- https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/simple-websocket-0.10.0[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
-BDEPEND="
- test? (
- dev-python/tornado[${PYTHON_USEDEP}]
- dev-python/websockets[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-python_test() {
- local EPYTEST_IGNORE=(
- # eventlet is masked for removal
- tests/common/test_async_eventlet.py
- )
-
- local EPYTEST_DESELECT=(
- # also eventlet
- tests/common/test_server.py::TestServer::test_async_mode_eventlet
- tests/common/test_server.py::TestServer::test_connect
- tests/common/test_server.py::TestServer::test_service_task_started
- tests/common/test_server.py::TestServer::test_upgrades
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/python-engineio/python-engineio-4.9.1.ebuild b/dev-python/python-engineio/python-engineio-4.9.1.ebuild
index bc862843428a..1112128be5ae 100644
--- a/dev-python/python-engineio/python-engineio-4.9.1.ebuild
+++ b/dev-python/python-engineio/python-engineio-4.9.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1