summaryrefslogtreecommitdiff
path: root/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fastimport/python-fastimport-0.9.6.ebuild')
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.6.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
deleted file mode 100644
index 6621e6e7c586..000000000000
--- a/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN#python-}"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Library for parsing the fastimport VCS serialization format"
-HOMEPAGE="https://github.com/jelmer/python-fastimport"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- "${PYTHON}" -m unittest fastimport.tests.test_suite \
- || die "Tests fail with ${EPYTHON}"
-}