summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
new file mode 100644
index 000000000000..f10324007a69
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}