summaryrefslogtreecommitdiff
path: root/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild')
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild
deleted file mode 100644
index 1cd53910dde3..000000000000
--- a/dev-python/python-ironicclient/python-ironicclient-0.9.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Ironic API"
-HOMEPAGE="http://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-CDEPEND="
- >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
-"
-CRDEPEND="
- >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
- >=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
- >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/python-openstackclient-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- ${CRDEPEND}
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- dev-python/doc8[${PYTHON_USEDEP}]
- >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/httpretty-0.8.4[${PYTHON_USEDEP}]
- <dev-python/httpretty-0.8.7[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- ${CRDEPEND}
-"
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}