summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index c3dfee70c7b2..e1e56fcc13b8 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,3 +1,4 @@
DIST python-lsp-black-2.0.0.gh.tar.gz 10399 BLAKE2B e38bf7ae736b3b71c1e17dd34b7e98b9bcbdbc7a12e2c1596ccdbe13b8fac8caef8a1f043aa50e1688b9159928885b8b116b709b4d2574b8ddf77172df756862 SHA512 e374ea34ac53e0d78ba198814210d9d7293e18b8fc7b22bb288621a994c8c9d492cc9c99c40cd1574b618add518671430e1e88f32e93e4c95507373932c08dc0
+EBUILD python-lsp-black-2.0.0-r1.ebuild 876 BLAKE2B 20c76c5055cf3f1a0265277ff056ddb9c8e38ed332c59f031e466660e6329d39b834674ba3bd5896eeb63b32bc2df069c44cf22c77c0af0df347edbabb137bed SHA512 0cd1bc971c12efd7b2315301431e7f41b5baced00fef19f99e7c7dd5a62f108481091b4624458541d91bbd6d55003c3164d39ae371466cf6537ec6ac5dac5ec8
EBUILD python-lsp-black-2.0.0.ebuild 873 BLAKE2B 941c470ddc388ff8fb1f2b16d3ce39d970bdbeb718bfeb478b46d45b9c635dc502a0647aaa6873cfd6229402e70fc86bcb806c54280fce0eb4a95279760ce4fe SHA512 7a59d2a6ebfc53da97fa28d46d04fcc292293c45c88e8672b0f59d006f6d66c8aff137ebc7b604272f09d80a9d87152781bf5270c0a68dfd6a68c0b1ca51b25c
MISC metadata.xml 517 BLAKE2B 2317a3c22a9269ad0228bcb89435ae9ce9f80cbd3eed68b5d7f995ef843cd08d17439d2764ed80cf2ccb27f1512a01f1eed010b601e9bb9355f3560aac54f7d8 SHA512 8936b9f60eb6e52b06fb3f663f1c4a58eee6c697d5c47488137dac85875028aa907e0f22515e88f4a90975ee1aea7781368f0398f8c6ab98728e12ce11cc899b
diff --git a/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild b/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3357a36a48a9
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-2.0.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-23.11.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ !!<dev-python/python-lsp-black-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}