summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild')
-rw-r--r--dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild
new file mode 100644
index 000000000000..68be8217ecf5
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JSON RPC 2.0 server library"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-jsonrpc/
+ https://pypi.org/project/python-lsp-jsonrpc/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/ujson-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}