summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-server
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.12.2.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index d0327c68045f..da80c7bd3d98 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,6 +1,8 @@
AUX python-lsp-server-1.12.0-jedi19-compat.patch 584 BLAKE2B 58aeb1c9370f3c028c2c8abf1c2ac85bd3bb4ad3af549d4e75bbf119973a0503c8822871c5614d6269e321674a04a6994ce6a49a300738304ce3d0e860f4cc9b SHA512 6b929110e1c9f27a87e7641bd4e5656b45d76db09a8b9c4a9319162a64a00ca3b604c164c71aedf83fd4eb2bdd4df1a1f128fde38279d904c562141e566fa257
DIST python_lsp_server-1.12.0.tar.gz 114328 BLAKE2B 3c94642be615822058debda5cb9de07529e7d269938029d66ade7eb7db801e7db90ae724f449e1133a813967e94bcfc71247f0392db1c495af5fff89ae66bd03 SHA512 74cbd8012f5e027fb117105302ba92e142900e88565d7f95d2dad72f2624048fff3c2c85085b648bd1ff86f6f6eb679aa34d5f6d9ae54b80e96b6ed472785b32
DIST python_lsp_server-1.12.1.tar.gz 115002 BLAKE2B 14d4b424fa0f36d0896d699505636934255ca0057257ba4fc447faf4058327e4e2afcffab3f7dc1e81a901c9c9070c4debc69f69a2c0745bec660bfaba1e58fe SHA512 6a457bd20c5d9113a64ddbbfaabc85c6129b3900bed298622e9fc344afa342eb3a91fd8c4aa795ace063d74369d4096327d464568b16f794257e07bbb1dca5a7
+DIST python_lsp_server-1.12.2.tar.gz 115054 BLAKE2B 5ee67de14e029dc0550d9ac412ce042357938783ae00435db7147921fa4923dd7f0df9c882ce3c54b43f03c9ebec2230444174920141efc17d67c2afaf406f5d SHA512 5a24fa6a8928a36498f50aa026f84478a4193e0991a4b83cad04a7ec131ca50c0d6104feb88c34721cbeab4900e4709b2ba21013aa232a197ee81d13b78c7a0b
EBUILD python-lsp-server-1.12.0-r1.ebuild 2794 BLAKE2B 9f6c5b9e5e6549628ac53a614ff171ce4611897faa4d83e9c5af42ba36df236a560d6b25bcb099046f46db6305d0cbce1985de3f4d7c819a8d11598d745418f7 SHA512 76d6a65651198ee07329f02b578c3d02929a4d228100cf82a47baf2e97d8ee92607664af1be72739dca85ee301e1e5096edd8f0cd29988da7eead843451e1c07
EBUILD python-lsp-server-1.12.1.ebuild 2676 BLAKE2B a485dd0635b08385bd27a0b0e72c53853bbbb65819586c3fb1e361d78338f72cd9b1701690017ff3345dfa2585f823120af3740fb4adfd7e21d612d5eb1513e8 SHA512 40621225754ed6c84691628d8cb4324645f38d78c1fe00b626ae2388197dffce44b11d90e57d89c28632303cac2c8ca5e99dc88926aca4e382087e2e7736ac04
+EBUILD python-lsp-server-1.12.2.ebuild 2676 BLAKE2B a485dd0635b08385bd27a0b0e72c53853bbbb65819586c3fb1e361d78338f72cd9b1701690017ff3345dfa2585f823120af3740fb4adfd7e21d612d5eb1513e8 SHA512 40621225754ed6c84691628d8cb4324645f38d78c1fe00b626ae2388197dffce44b11d90e57d89c28632303cac2c8ca5e99dc88926aca4e382087e2e7736ac04
MISC metadata.xml 597 BLAKE2B 2b7babd22792b973dd6eb9c7f127e4e91b4e534a36662c9f773c5a27aaedfd676fb31eaab4e5b337bb203ae8729e0e2ac8f31a8e7edc6695a7b7967b51fec1da SHA512 1d6a89489d5f701d259b9d1e200fbdf51b368258556c9b66efb313690f3551c089bd03935ff95e73845b79e5ec5031b2f34eea7a853f1f8de8b88abcb2f09663
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.12.2.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.12.2.ebuild
new file mode 100644
index 000000000000..7b340b993f04
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.12.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-server/
+ https://pypi.org/project/python-lsp-server/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="all-plugins"
+
+PLUGIN_DEP="
+ >=dev-python/autopep8-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/flake8-7.1[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-3.1[${PYTHON_USEDEP}]
+ >=dev-python/rope-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.1.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ ${PLUGIN_DEP}
+ )
+"
+BDEPEND="
+ test? (
+ ${PLUGIN_DEP}
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/qtpy[gui,testlib,${PYTHON_USEDEP}]
+ )
+"
+
+# Note: xdist breaks some tests
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ # unpin all the deps
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by presence of pathlib2
+ 'test/plugins/test_autoimport.py'
+ # Requires pyqt5
+ 'test/plugins/test_completion.py::test_pyqt_completion'
+ )
+ local EPYTEST_IGNORE=(
+ # pydocstyle is archived upstream and broken with py3.12
+ test/plugins/test_pydocstyle_lint.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}