summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine/python-redmine-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-redmine/python-redmine-2.4.0.ebuild')
-rw-r--r--dev-python/python-redmine/python-redmine-2.4.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/python-redmine/python-redmine-2.4.0.ebuild b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
index da55d3bf3c50..1492e5810aa4 100644
--- a/dev-python/python-redmine/python-redmine-2.4.0.ebuild
+++ b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -25,6 +25,12 @@ RDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # https://github.com/maxtepkeev/python-redmine/pull/332
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
epytest -o addopts=
}