summaryrefslogtreecommitdiff
path: root/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild')
-rw-r--r--dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild b/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild
deleted file mode 100644
index ce075107d563..000000000000
--- a/dev-python/python-senlinclient/python-senlinclient-1.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Senlin API"
-HOMEPAGE="https://github.com/openstack/python-senlinclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/openstacksdk-0.9.10[${PYTHON_USEDEP}]
- !~dev-python/openstacksdk-0.9.11[${PYTHON_USEDEP}]
- !~dev-python/openstacksdk-0.9.12[${PYTHON_USEDEP}]
- >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/python-heatclient-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # built in...
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}